Contact

Amibian © Gunnar Kristjánsson 2019

Amiga is copyrighted by Amiga Inc. Kickstarts are copyrighted by Cloanto Inc.

No copyrighted material is found in Amibian.

amigafan2003
Feb 7

3.1.4 rom not found in Amiberry or UAE4ARM

4 comments

Edited: Feb 7

Hi

 

Fresh install of Amibian, latest release.

 

I've created a hdf through WinUAE with ClassicWB + BestWB + Workbench 3.1.4. The problem is Amiberry or UAE4ARM doesn't see the 3.1.4 rom (either in drop down list or manually browsing) - just finds the "normal" 1.3 / 2.05 / 3.1 roms I've dropped in there also. Obviously the hdf wont boot on any other rom (modules.library not found).

 

On the Amiberry github, they've added the rom to the rommgr.cpp file but running an download/recompile of Amiberry within Amibian doesn't seem to pull the file in.

 

Any ideas?

Phalkon13
Feb 28Edited: Mar 15

Since Amibian has not been updated since before 3.1.4 came out, I am guessing it wouldn't support it (same as Amibian not supporting Cyberstorm or other PPC plugins but support other specific hardware plugins)

 

EDIT: Apparently I can't read. Since you pulled the latest version of Amiberry, I am wondering if it might be more of a "whitelist" type of thing where the emulator is looking for a specific file.

Phalkon13
Mar 15

Additionally, have you tried replacing one of the known-working KS files with the 3.1.4 KS to see if it works?

amigafan2003
Mar 15

I fixed it - bit of a daft mistake tbh. The 3.1.4 KS does not have a .rom file extension. Not a problem when using it in WinUAE but looks like Amiberry expects it. I added .rom to the file name and now ok.

Phalkon13
Mar 15

Awesome to hear you got it working! Thanks for letting us know. I know eventually I'm going to grab a copy of 3.1.4, so I know this will be helpful for me. I am sure this info will be helpful for others as well :)

New Posts
  • crossconnect4u
    a day ago

    While looking through troubleshooting stuff for SD card problems I stumbled across this page and found out something new. You can boot your Pi from USB, but it appears to be a one way deal and permanent. I remember earlier there was a way to boot from the SD and switch to USB. I may go that route if my read/write problems don't stop. See link below: https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md
  • dlma71ny
    Sep 20

    Amibian 1.4 doesn't work on RPi 3A+. Has anyone been able to get it working? Thanks in advance!
  • thorsteinsson
    Sep 12

    Hello there. Apologies if this has been asked before. I intend to purchase a Raspberry Pi purely for Amiga emulation, and was wondering if there are any benefits to getting a Pi 4 in terms of performance? Perhaps less lag or something similar? I am aware that there aren't many builds for the Pi 4 just yet. Thanks.
This site was designed with the
.com
website builder. Create your website today.
Start Now