Contact

Amibian © Gunnar Kristjánsson 2019

Amiga is copyrighted by Amiga Inc. Kickstarts are copyrighted by Cloanto Inc.

No copyrighted material is found in Amibian.

MrOffthespectrum
Apr 5, 2018

Wifi on Pi 3b+

13 comments

Hello all, long time lurker here :)

I need some help connecting to wifi (or someone to tell me my Pi is currently unsupported). 48 hours and loads of unsuccesful attempts have gotten the best of me. Time to ask for help!

After giving up yesterday I decided to do a fresh image burn (just to be sure) of Amibian and just configured my ssid+pw again using the "wifi" command, still nothing. When I type it ifconfig -a, i get eth) and Lo but no Wlan. I'm sick of staring at this blue screen, I want to get to the fun bits :)

wizzel
Apr 7, 2018

You need to select your Wifi Country in the Wifi-Config with the new 3 B+.

Otherwise Wifi will refuse to work.

ClassiC
Apr 10, 2018

I am struggling with the same issue. Wifi Country is NOT the solution for me. =(

 

Gunnar told me that there is a [not specified] problem and that it will take some time to fix it.

 

@wizzel: Really, bro? You run Amibian on 3 B+ and wifi is working?

 

@all: What about other 3 B+ users? Who was able to activate wifi? And how?

marcomto.mm
Apr 17, 2018

Here the same problem PI 3B+. I discovered by typing dmesg that the bios files are missing. You need these two files

- brcmfmac43455-sdio.bin

- brcmfmac43455-sdio.txt

 

in the following path: /lib/firmware/brcm/

 

Then configure wifi as described in this site. Don't forget to setup your country, otherwise wifi won't be enable.

 

Hope it helps.

keith.f.kelly
Oct 25, 2018

It would help if I knew where to get those files from...

ClassiC
Nov 1, 2018

Is wifi working on amibian and raspi 3b+ now? YES or NO?

keith.f.kelly
Nov 1, 2018

Yes, it works if you copy the brcrm files as already explained above.

ClassiC
Nov 1, 2018

@keith.f.kelly

thx! =)

wilcommultitechniek
Nov 18, 2018

OKe i'm total noob on a linux computer.

So where and how to setup your country in the wifi config ?

wilcommultitechniek
Nov 18, 2018

OKe i'm total noob on a linux computer.

So where and how to setup your country in the wifi config ?

sirmetal
Jan 18

Did the same as you and it worked at last. Thanks for the link.

 

johannes.bittner
Feb 9

This worked for me as well! Thanks a lot

New Posts
  • ralfmikuteit
    Oct 2

    Hello, When i installed AMibian to SD, The Rasperry 4 is not booting. What can i do?
  • tc.bednarz
    Oct 14

    I created a new Hardfile with the emulator. I mounted the hardfile as UAE and as IDE drive but HDToolBox can‘t find a Harddrive and no harddrive shows on the workbench screen
  • raoulangel
    Sep 28

    Hi! I've written about this before but I think I have been dancing around the issue.. to be more specific... I would like to emulate an Amiga 2000, with the ability to use Video Toaster and run Lightwave. (That probably isn't emulated yet but I want the config to have the ability) Obviously 640 x 400 is not the resolution for that, and I have seen much better. How do I do this? Does anyone have an image configured I could use? Thanks!
This site was designed with the
.com
website builder. Create your website today.
Start Now